transmission-cli: command not found

Have You tried accessing the binary with the full path?

Maybe Your $PATH variable doesn't contain the default paths? echo $PATH should give something like:

[root@server ~]# echo $PATH
/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

If it's empty, You may set the PATH variable with this command

export PATH="/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin"

On CentOS possible default full paths are:

/usr/bin/transmission-cli - from package: transmission-cli

You may install the required package with command yum install {package}

On Debian possible default full paths are:

/usr/bin/transmission-cli - from package: transmission-cli
/usr/lib/debug/usr/bin/transmission-cli - from package: transmission-dbg

You may install the required package with command apt-get install {package}
Error in other languages:
transmission-cli: bevel nie gevind nie
transmission-cli: comandă negăsită
transmission-cli: comando não encontrado
transmission-cli: commande introuvable
transmission-cli: command not found
transmission-cli: käsku ei ole
transmission-cli: không tìm thấy lệnh
transmission-cli: komanda nerasta
transmission-cli: Kommando nicht gefunden.
transmission-cli: kommandot finns inte
transmission-cli: komut yok
transmission-cli: nie znaleziono polecenia
transmission-cli: níor aimsíodh an t-ordú
transmission-cli: no se encontró la orden
transmission-cli: no s'ha trobat l'ordre
transmission-cli: opdracht niet gevonden
transmission-cli: parancs nem található
transmission-cli: perintah tidak ditemukan
transmission-cli: príkaz nenájdený
transmission-cli: příkaz nenalezen
transmission-cli: команда не найдена
transmission-cli: командата не е открита
transmission-cli: 命令找不到
transmission-cli: コマンドが見つかりません