sphinx-1.0-autogen: command not found

Have You tried accessing the binary with the full path?

Maybe Your $PATH variable doesn't contain the default paths? echo $PATH should give something like:

[root@server ~]# echo $PATH

If it's empty, You may set the PATH variable with this command

export PATH="/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin"

On CentOS possible default full paths are:

/usr/bin/sphinx-1.0-autogen - from package: python-sphinx10

You may install the required package with command yum install {package}
Error in other languages:
sphinx-1.0-autogen: bevel nie gevind nie
sphinx-1.0-autogen: comandă negăsită
sphinx-1.0-autogen: comando não encontrado
sphinx-1.0-autogen: commande introuvable
sphinx-1.0-autogen: command not found
sphinx-1.0-autogen: käsku ei ole
sphinx-1.0-autogen: không tìm thấy lệnh
sphinx-1.0-autogen: komanda nerasta
sphinx-1.0-autogen: Kommando nicht gefunden.
sphinx-1.0-autogen: kommandot finns inte
sphinx-1.0-autogen: komut yok
sphinx-1.0-autogen: nie znaleziono polecenia
sphinx-1.0-autogen: níor aimsíodh an t-ordú
sphinx-1.0-autogen: no se encontró la orden
sphinx-1.0-autogen: no s'ha trobat l'ordre
sphinx-1.0-autogen: opdracht niet gevonden
sphinx-1.0-autogen: parancs nem található
sphinx-1.0-autogen: perintah tidak ditemukan
sphinx-1.0-autogen: príkaz nenájdený
sphinx-1.0-autogen: příkaz nenalezen
sphinx-1.0-autogen: команда не найдена
sphinx-1.0-autogen: командата не е открита
sphinx-1.0-autogen: 命令找不到
sphinx-1.0-autogen: コマンドが見つかりません